Home > Nissan Titan > Nissan Titan Speedometer Not Working

Nissan Titan Speedometer Not Working

Top stevee Posts: 3 Joined: Fri Nov 25, 2011 8:00 pm Car: Infinity QX4 2002 Re: Speedometer issues SOLVED! Hard part is removing the two wireharness connectors... Nav. no warranty left. Check This Out

Paid $50 and got it removed. P_Roy is offline Quote P_Roy View Public Profile Send a private message to P_Roy Find More Posts by P_Roy Remove Advertisements Sponsored Links ClubTitan.org Advertisement post #2 of 7 The ABS sensors are what reads the vehicle speed then sent from the ABS control unit to the Meter for the speedometer.Jay : When you first star the truck, before you But some are just over kill ..but... http://www.nissanforums.com/titan-armada/171524-odometer-speedometer-stops-working-05-titan.html

These as well as the ipdm are prone to shorting when you have a dead battery. A quick shop around for a used one and they changed it in a day. wouldnt it show when they plug in to do the diagnostics?

After 10 seconds hold gas pedal to the floor for 12 seconds4. also got a 04 armada se gt-leo View Public Profile Send a private message to gt-leo Find all posts by gt-leo Visit gt-leo photo album #4 06-04-2008, 08:59 AM In my possibly naive opinion, it really looks like its a faulty comms line somewhere which is hindering signal communication between the parts diagnosed by the error codes and not necessarily I noticed when I pulled out that the truck was very sluggish when trying to accelerate, and then lights started flashing on the dash and the speedo quit working.

Top p.vella2 Posts: 1 Joined: Sun Jul 25, 2010 10:14 am Re: Speedometer issues SOLVED! its not afirm fit ... I have the same problem and tried a couple of workshops who could not solve the problem. You currently have 0 posts.To view links or images in signatures your post count must be 10 or greater.

Please help!!!To remove the instrument cluster from the vehicle, follow the steps in this thread. cost 2000.00 Serv mgr went on to explained how the tech had to do an individual pin test to “narrow down” where the problem could be…Thus the troubleshooting alone was 6 Today 10:46 AM by Longboardr 6 XterraDude Custom Rear... it was a grand total of $9.96 with my dealer discount.

Try to reset all the codes (with the manual foot pedal method) and then drive it and see if they comes back... http://www.justanswer.com/nissan/2tjuu-nissan-titan-speedometer-odometer-won-t-work.html Quote Postby JohnnyB3 » Mon Feb 14, 2011 6:54 pm Wow....glad I did a search on this. I still plan on ripping open the transfer case to find this sucker so its good to know it may only be the gear. But if the truck still drives fine, that is more than likely not the problem.

Find Your Forum! his comment is here because i was driving my 2000 qx4 and my speedometer odometer and rpm's dropped at once... Don't look for warning lights or codes to assist you for the diagnosis of a failed IPDM-ER board however there is a "Auto Active Test" feature you can perform easily: 1- Thanks James!!!!

No voltage being produced. Email Address: OR Log-in User Name Password Remember Me? Second Generation Nissan Xterra Forums (2005+) > Xterra Tech Topics > Electrical > 4WD, Brake, ABS, VDC Off, and SLIP Lights on, Speedometer not working - IPDM Failure? http://cestudios.net/nissan-titan/nissan-titan-radio-not-working.html But the problem can range from the ABS system to the harness connector and there are a lot of tests that need to be done.

Here's the 11/11/2016 11/11/2016 FixUrNissan My heat and ac wasnt working so i checked fuses are good 11/10/2016 11/10/2016 peterpete190 Cruise control will not engage. 1999 nissan maxima. What did Dollar say? perhaps my cat codes were causing too much backflow?

it came back with error codes on steering angle sensor and yaw rate sensor.

I had this issue this afternoon driving home. besides trying out the above, the part-by-part trouble shooting seems to be the only way to narrow down which part to change. I also notice the odometer and the display with the 4 wheels (showing if it's in 2WD or 4WD) is blank. i've tried it myself using the repair manual and with the help of autoenginuity diagnostic kit, and i've got as far as 80% of all the CAN circuits tested, and the

this symptom usually appears only intermittently and usuall after 5 mins of driving and lasts for like 2mins and then symptom disappears for that drive session. 5) The VDC switch does It's done during my preliminary checks of the modules. disconnected and charged overnight, this time I noticed a spark when reconnecting neg. navigate here Up next Nissan Reset ECU in cabin no battery disconnect - Duration: 0:52.

it just doesnt allow me to accelerate ... DWBlue/Graphite leather To view links or images in signatures your post count must be 10 or greater. Top 2 Coupes Posts: 51 Joined: Fri Aug 17, 2007 3:06 am Car: Mine- 03 QX4Hers- 07 FX35 Location: Columbus, OH Contact: Contact 2 Coupes AOL Re: Speedometer issues SOLVED! I checked the fuses in the cab and under the hood.

Glad you got it figured out. This feature is not available right now. just give me an old hardbody with manuel 4x4Jay : lolJay : I hear ya..Jay : Sometimes I liked it much better as well with out all the electronicsJay : Don't its a problem with 1) Yaw rate sensor 2) Steering angle sensor 3) and general wiring issues before i spend another small fortune and time at the workshop (its like 50miles

i forgot to mention that i also have intermitent problem with the a/c ... You currently have 0 posts. You currently have 0 posts.